Back to overview
Resolved
System Upgrade
Aug 21, 2026 at 6:05am UTC
–
Aug 21, 2026 at 8:05am UTC
Affected services
Platform Console
API Services
Bio Page Services
Event Services
Recruitment Services
Resolved
Aug 21, 2026 at 8:05am UTC
Maintenance ended
Affected services
Created
Aug 21, 2026 at 6:05am UTC
Upgrading OEASE system to support MCP!
Affected services